Moneyd - connect to ETH testnet

#1

Dear all,

Together with my colleagues I’m working on a PoC with ILP. The original post:
Interoperability prototype with moneyd

I tried to google and find some kind of tutorial how to setup Moneyd connector for ETH testnet. It must be testnet - internal policy. When I run moneyd eth:configure (–testnet) I noticed that there’s a different BTP connector depending on my testnet flag.
test.ilp.kava.io/eth
ilp.kava.io/eth
Reading github pages for ilp-plugin-ethereum - mainnet is mentioned but nothing about testnet.
I wondered if someone can point us in the right direction on which testnet to use and to generate our private key that will be able to connect to BTP connector test.ilp.kava.io/eth and than hopefully finish our experiment.
Thank you!

#2

Hi Joe,

We made this documentation for a hackathon a few months ago. It walks through how to connect to the XRP and ETH test nets. Let me know if you have any other questions.

Best,
Austin

#3

moneyd-uplink-eth probably doesn’t work since it’s using an older version of the plugin, and isn’t compatible with our connector. Broadly though, moneyd isn’t really architected well for payment channel management, and in part because of that, there isn’t a great way to update the ETH uplink to work with newer versions of the plugin.

The testnet Ethereum connectors use the Kovan testnet, and you can request some kETH at this faucet.

(Strata’s connector may work with the older version, but I’m not entirely sure).

#4

Thank you both for your answers. I setup the connector following @austin_king reply but it seems that:

@kincaid is right. I tried to setup the connector using moneyd (also trying different versions of the uplink) and running the configure with different BTP hosts:
btp.strata-ilsp-3.com:8080
test.ilp.kava.io/eth
and they both return: fatal: TypeError: Cannot read property ‘Eth’ of undefined in index.js

#5

@ joe_ke Hi Joe, did you sort this out?

#6

Hi @joe_ke ,

today I ran into the same issue as you did: TypeError: Cannot read property ‘Eth’ of undefined in index.js

While I am not certain, I think there was an API change when using convert and related asset units. So I made some modifications to the index.js in interledgerjs/moneyd-uplink-eth. Using this patch, I could configure and start the ETH moneyd.

However, sending packets was not possible, they were either rejected due to T04 “Exceeded maximum balance” or F08 “Packet size is too large”. moneyd was connected to test.ilp.kava.io/eth and the balance configuration was as follows:

"balance": {
    "maximum": "0.02",
    "settleTo": "0.005",
    "settleThreshold": "0.01"
},

Maybe this helps to some degree. I will certainly continue testing it.