Setting up moneyd on ubuntu 18

Hello all,

Please forgive me if this has come up before, but I am having some issues running moneyd on an ubuntu 18 VM. I followed the basic steps of:

npm install -g moneyd moneyd-uplink-xrp
moneyd xrp:configure --testnet
moneyd xrp:start --testnet

but I keep getting the following error when running the last command:

2019-05-17T03:16:23.128Z connector:app error Error: {"code":"F00","name":"NotAcceptedError","triggeredAt":"2019-05-17T03:16:23.088Z","data":"sodium.sodium_malloc is not a function","protocolData":[]}
    at Plugin.callback (/home/cjimison/.nvm/versions/node/v10.15.3/lib/node_modules/moneyd-uplink-xrp/node_modules/ilp-plugin-btp/src/index.ts:666:20)
    at Plugin.listener (/home/cjimison/.nvm/versions/node/v10.15.3/lib/node_modules/moneyd-uplink-xrp/node_modules/eventemitter2/lib/eventemitter2.js:290:17)
    at Plugin.EventEmitter.emit (/home/cjimison/.nvm/versions/node/v10.15.3/lib/node_modules/moneyd-uplink-xrp/node_modules/eventemitter2/lib/eventemitter2.js:357:19)
    at Plugin._handleIncomingBtpPacket (/home/cjimison/.nvm/versions/node/v10.15.3/lib/node_modules/moneyd-uplink-xrp/node_modules/ilp-plugin-btp/src/index.ts:711:14)
    at Plugin._handleIncomingWsMessage (/home/cjimison/.nvm/versions/node/v10.15.3/lib/node_modules/moneyd-uplink-xrp/node_modules/ilp-plugin-btp/src/index.ts:528:18)
    at WebSocketReconnector.EventEmitter.emit (/home/cjimison/.nvm/versions/node/v10.15.3/lib/node_modules/moneyd-uplink-xrp/node_modules/eventemitter2/lib/eventemitter2.js:354:19)
    at WebSocket._instance.on (/home/cjimison/.nvm/versions/node/v10.15.3/lib/node_modules/moneyd-uplink-xrp/node_modules/ilp-plugin-btp/src/ws-reconnect.ts:133:70)
    at WebSocket.emit (events.js:189:13)
    at Receiver.receiverOnMessage (/home/cjimison/.nvm/versions/node/v10.15.3/lib/node_modules/moneyd-uplink-xrp/node_modules/ilp-plugin-btp/node_modules/ws/lib/websocket.js:789:20)
    at Receiver.emit (events.js:189:13)

as seen above I am running a NVM installed copy of Node.js on version 10.15.3 but I also tried with 12.2.0 and got the same error. I have also done the following with no success:

  • apt install libsodium21
  • npm install -g sodium-native
  • npm install -g sodium

This is on mostly clean version of Ubuntu Server 18 with build-essential, automake, and libtools installed (with the other base packages that comes with the default distro). Any help would be GREATLY appreciated!



Hi Chris,

Generally Moneyd-xrp is well maintained and should work. Problems appear when the plugins do not match (the same plugin versions should be installed on Moneyd and the connector you are connecting to, in this case Amundsen), OR because of a configuration error.
Regarding starting up with Moneyd, you can read this post:
What settings did you use? Can you post the config?

Hi Lucian,

Thanks for your response and the posted article is where I got the 3 commands to install, configure and run moneyd. I highly suspect that I am doing something wrong from a setup perspective (missing or incorrect version of a library, etc). Below is the .moneyd.test.json that was auto generated via the command moneyd xrp:configure --testnet:


  "version": 1,
  "uplinks": {
    "xrp": {
      "relation": "parent",
      "plugin": "/home/cjimison/.nvm/versions/node/v10.15.3/lib/node_modules/moneyd-uplink-xrp/node_modules/ilp-plugin-xrp-asym-client/index.js",
      "assetCode": "XRP",
      "assetScale": 9,
      "balance": {
        "minimum": "-Infinity",
        "maximum": "20000000",
        "settleThreshold": "5000000",
        "settleTo": "10000000"
      "sendRoutes": false,
      "receiveRoutes": false,
      "options": {
        "currencyScale": 9,
        "server": "btp+wss://",
        "secret": "snQ4apuDWBHp72q54R5QR7uo8nHU4",
        "address": "rpnaLp3ovzcWL8TBw5EtrHqG1vm3t4ZFva",
        "xrpServer": "wss://"

Thanks again for the help!


As a follow-up it seems like others have had this issue and have posted on the Gitter channel here:

No resolution found there as well.

Since it’s in a btp response, this error originates from the Strata connector. Pinging @austin_king, apologies if I’m reading this wrong.

1 Like

I got a work around. Someone on Gitter helped me out with this one:

  • Delete .moneyd.test.json
  • run: moneyd xrp:configure --testnet --advanced
  • When asked for the btp host enter:
  • Press enter for the default options after
  • once done run: moneyd xrp:start --testnet

After that everything worked.


I’m having the same problem but on MacOS. I’ve tried using nvm with node versions 8 and 10. I also tried manually installing libsodium using the latest tarball but error persists when trying to start up with moneyd xrp:start --testnet. My config looks identical to the post above except for local file paths. Looking forward to a resolution, thanks!

This worked. Thank you.

1 Like